Downgraded Performance

Incident Report for LinkIt!

Resolved

All LinkIt operations have returned to normal. Thank you for your patience as the issue was resolved.
Posted Sep 15, 2026 - 11:29 EDT

Investigating

We are aware of downgraded performance on the LinkIt platform. We will update this status message as soon as the issue is resolved.
Posted Sep 15, 2026 - 11:07 EDT
This incident affected: US Production Environment (LinkIt! Portal, Bubble Sheet Service, Reporting, Intervention Manager).