We are aware of downgraded performance of the LinkIt platform. We will update this status message as soon as the issue is resolved.

Incident Report for LinkIt!

Resolved

Thank you for your patience as we identified and resolved the issue. All operations have returned to normal.
Posted Apr 02, 2025 - 09:18 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 02, 2025 - 08:59 EDT
This incident affected: US Production Environment (LinkIt! Portal, Student Test Taker, Bubble Sheet Service, Reporting, Intervention Manager).