LinkIt Performance Issue

Incident Report for LinkIt!

Resolved

Thank you for your patience as our team identified and resolved the issue. All LinkIt operations are once again fully functional.
Posted Mar 11, 2026 - 11:57 EDT

Update

We are continuing to work on a fix for this issue.
Posted Mar 11, 2026 - 11:45 EDT

Identified

We are aware of downgraded performance of the LinkIt platform and we will update this status message as soon as the issue is resolved.
Posted Mar 11, 2026 - 11:37 EDT
This incident affected: US Production Environment (LinkIt! Portal).