Downgraded Performance

Incident Report for LinkIt!

Resolved

All LinkIt operations have returned to normal. Thank you for your patience as the issue was resolved.
Posted Mar 17, 2026 - 10:39 EDT

Update

The LinkIt team is continuing its investigation of the downgraded performance of the test taker service. We suspect this is part of a larger issue affecting global Amazon Web Services across several regions. We will update this message as soon as the issue is resolved.
Posted Mar 17, 2026 - 10:03 EDT

Identified

We are aware of downgraded performance of the LinkIt platform and within the Student Test Taker. We will update this status message as soon as the issue is resolved.
Posted Mar 17, 2026 - 09:00 EDT
This incident affected: US Production Environment (LinkIt! Portal, Student Test Taker, Bubble Sheet Service, Reporting, Intervention Manager).